ERPNext Mobile on Android Store!

I don’t think so. Easiest fix I can think of is setting up nginx to redirect to https if someone connects on port 80.

Did it, still won’t work, no error message. Could it be that the app is not accepting the self-signed certificate?

Same problem here, I use self signed certificates, plus in my case, I proxy the https from another server (I have to do it this way for now). Works perfectly on the browser (https).

Did you figure it out ?

I did not. It would be easier if they gave us a popup with the error message.

Yes, I also have no error message, nothing. I tried to connect to a non-existent server on ( and got a message saying that there is no server at the address. But if I try with my self-hosted server, I get nothing. Maybe the app is not ready for self-hosted ?

Also, if someone knows of a way to debug an android app (log files somewhere?), I could have a look …

The problem is that the connection times out. Maybe we need an aggressive time out for this.

We want to hold a bit before releasing the Cordova containers for sometime.

Yes looks like it times out. But if it does, could it be that we have to forward another port to the server ? I read here that it’s supposed to use only https, but my https works.

If you don’t specify “http://” or “https://” in your server id, it will try https: first. If it errors, it will try http:

Not sure how to debug this, but please add a GitHub issue.


adb logcat > log.txt

The only problem is by using the above command it generates very heavy log.txt in short time. Then you can search the log.txt.

There is also QtAdb which is a gui for adb. It also has a logcat button.

Hello community.

I want to know if some one have a problem printing invoices or saving invoices as pdf. I’m testing the print function in a Nexus 4 and a 7in tablet… an error is raised.

Seems like an issue (the url must be absolute). Can you add it to github.

I’m having an invalid request? I was able to login but when I try to access the modules, I got an invalid request.

Server is on a VPS location. Did I forgot to install something on the VPS? Kindly advice.

Http seems good but I’m having this error on mobile. Thanks

@kroger reload the page i.e clear cache

if its not worked do bench update

Issue #12

Issue added to bitbucket.

The mobile app was working fine for me on an earlier setup, but now it simply doesn’t connect, no error message. I suspect it’s an nginx-SSL problem. I’m using a valid commercial SSL certificate, and it recognized and connected before with no problems. But my nginx setup is different now. [EDIT] I’m using the default ERPnext nginx.conf — I think the problem lies in this file.


I know mobile offline is extreme difficult to implement. Is it possible to step by step to implement? Such as: todo, calendar. It usually personally use them and sync. back to server after online, then share to others.


1 Like

is there anyway to get this app if you do not have access to google services (due being in a location that blocks it for example)?

1 Like

I have the same question. Submitting to F-droid would be perfect, but ability to download .apk will still help a lot. Thanks.


erpnext android apk

Sure, but how will you check integrity of the app? I meant the officially published package.