ERPNext module cannot be found even it is installed in the site already

I installed frappe in a remote server and when I tried accessing it in the browser I am getting this error. Is there anyone had encountered and solved this issue?

When I run bench --site all list-apps erpnext doesn appear but when I run bench --site mynewsite.local install-app erpnext it says “App erpnext already installed”.

Does anyone have any idea how to solve this?

Stop the bench, again start the bench, migrate the site, and check it.

If not work then uninstall the erpnext, again install it and migrate it.

1 Like

When I tried bench migrate the erpnext app appears already when I run bench list-apps. The problem is that ModuleNotFoundError: No module named 'erpnext' still appears when I’m trying to access it in the browser.

bench --site sitename clear-cache
bench build --force

Otherwise, create a new site and check it.

Thank You!

Is there any other way except creating a new site?

Update the site and check it.

bench update --reset

If not work then create a new site and check it.

Thank You!

Hi it seemed to be working up until this error came up.

I am having that error since I installed the frappe-bench. Is this because python3.12 is being used for the site-packages?

Hi @Rabie_Moses_Santill1,

For ERPNext versions 14 and 15, the minimum required Python version is 3.10.

Please check the post.

Thank You!