ERPNext on Ubuntu 14.04

Dear ERPNext Admin,

I am new in ERPNext. I am tried many times install ERPNext on Ubuntu 14.04.
Followed this installation process described in that i followed that link…/erpnex…/Wc9gUbKzMwg/dzKC0o40HRoJ.

But still i can’t install ERPNext.
Pls give me a ERPNext 4 install process on ubuntu 14.04 32 bit os with clear instruction in detail.
Pls help me.


Installing through latest updates works without any problem.

Dear Md_Hafizur_Rahman,
If you can help me with server details or remote sharing/access of your server then I might help you in installation.

Did you run the easy install script?
After, running the easy install script, change to frappe user using the command, su -frappe and init a bench. Follow GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps

Yes I run easy install script.But can’t install .

Please post the error.

I also tried the easy install on Ubuntu 14.04.1

Received error “add-apt-repository: command not found”

Run this and try again

That got me a little further, here’s the next error encountered

Installing wkhtmltopdf
Selecting previously unselected package wkhtmltox.
(Reading database … 36040 files and directories currently installed.)
Preparing to unpack wkhtmltox-0.12.1_linux-trusty-amd64.deb …
Unpacking wkhtmltox (0.12.1) …
dpkg: dependency problems prevent configuration of wkhtmltox:
wkhtmltox depends on libxext6; however:
Package libxext6 is not installed.

dpkg: error processing package wkhtmltox (–install):
dependency problems - leaving unconfigured
Processing triggers for man-db ( …
Errors were encountered while processing:

updated the script to include that, can you try again with a fresh install on ubuntu?

Installed wkhtmltopdf manually from this link [][1]
(had to create /usr/local/bin directory before I could do ln command)

Then reran the sudo bash --setup-production command

Got further in the process - while progressing encountered these errors line 298: hash: pip-2.7: not found line 300: hash: pip2.7: not found

Created a fresh instance of Ubuntu 14.04 and retried the easy install script - btw - running it on a OpenVZ container

I received these errors again along the way line 298: hash: pip-2.7: not found line 300: hash: pip2.7: not found

but it appears that all installed, no further errors

So now the easy install is complete - what’s next? There isn’t a directory to point to in var/www/html, not sure if we need to create something else, or is it really set to go

Did it print “setting up first site, etc”

Did it print three passwords or did it return to shell?

Yes it did do all that - but where do you go from there?

There are no files in the /var/www/html/ folders, what is the next step after the easy install, I have not been able to find a next step after easy install.

here’s the output from the easy install

root@erp:~# sudo bash --setup-production
DEBUG Ubuntu trusty amd64 amd64
Adding debian mariadb repo
Installing packages for Ubuntu. This might take time…
Installing wkhtmltopdf
Adding frappe user line 298: hash: pip-2.7: not found line 300: hash: pip2.7: not found
Installing frappe-bench
Setting up first site

Frappe/ERPNext is installed successfully.
Frappe password: XXXX
MariaDB root password: XXXX
Administrator password: XXXX

The passwords are also stored at ~/frappe_passwords.txt
You can remove this file after making a note of the passwords.

It’s all done, ERPNext should be running on port 80. What’s the output of curl -I localhost?

bash: curl: command not found

So I installed curl - and now

HTTP/1.1 200 OK
Date: Tue, 11 Nov 2014 18:46:40 GMT
Server: Apache/2.4.7 (Ubuntu)
Last-Modified: Mon, 21 Jul 2014 19:21:35 GMT
ETag: “2cf6-4feb903eb4dc0”
Accept-Ranges: bytes
Content-Length: 11510
Vary: Accept-Encoding
Content-Type: text/html

If I go to the ip address of that instance, it just shows the Apache2 Ubuntu Default Page

Can you stop/remove Apache and start/restart nginx and try again?

ok great - so that got me to the login page

I’ll just have to configure those to start automatically

Thanks very much for the assistance!

Does ERPNext have it’s own mail server or do we have to have something setup?

Upon first login, I think we need to enter a new user username and email address, and system says registration details emailed, but never received it.

Or do we use an admin login or some other userid?

I know there’s frappe passwords, is there a userid we use with those passwords?

You would have to configure your own email server. Just search for 'Outgoing Email Settings' in the top bar. After which ERPNext will start utilizing this email for sending across emails/notifications.

The first user/email id which you set up is created as the system administrator so you can login with this id.

Hope this helps.

- Omkar