ERPNext Setup Wizard hangs at step 5 without any error

I installed ERPNext in VirtualBox on a Mac, followed all the instructions including running bench update. I can access ERPNext after running bench start on my browser, but as soon as I press next in the 5th step (Company Information) in the setup wizard, it hangs / stops with no error in the console log or terminal. I tried it several times in both Firefox and Google Chrome, and waited for a long period all the times, but it just stops there.

I have tried both the Development and Production images, and I am facing this problem, without it giving me any errors in both.

Has anyone else faced this? any suggestions?

Not able to replicate the issue. Are you still facing this?

Please try again by pulling latest updates and reinstalling the site. If issue persists, please share a screenshot.

Ok, before I start, I have been told by others in the past that my solution to this was irrelevant and should not have worked, but it did work and now I never have the problem anymore. My experience with it indicates I was right. I work on Linux systems, but the principles are the same.

A few months ago I was having trouble getting through the first Administrator login and configuration step after switching from dedicated local server box to a VM environment. At some point during the initial setup the system would hang and I would have to shut it down and restart it to try again. It turned out that I did not have enough resources assigned to the VM environment.

I started adding memory and CPU time a little at a time and retesting. Eventually I reached a point where I could get through the initial login and configuration, but then would run into other system lockups when trying to import data or search existing data.

It was not until I had a VM instance running with somewhere around 4gb of memory and a full CPU that everything started working smoothly. The more I asked the system to do and the more data I had in the system, the more memory it seems to need to run efficiently. While this may not be the problem in your case, it is at least worth knowing that the VM environment plays an important role in how well your ERPNext VM instance will operate. My best performing. and least troublesome VM instance is configured for 16gb of memory and the ability to use 2 CPU’s.

I do not know anything about a Mac PC or it’s native OS. However, all VM environments work in pretty much the same way. The more resources you give it to operate, the better it will run your image. The application has no way to tell you that it is running out of memory or that the CPU is running at 100% and cannot keep up. It is up to you to add resources and monitor the difference in performance.

Hope this gives you a starting point for solving your issue.


Yes, I am still facing the issue. I could proceed to the last step after selecting another country from the list, but it still gives me an error in the last step. I will try to share a screenshot.

The step 5 hanging issue seems to be a timezone problem. I had selected Afghanistan, and it would stop there, but once I choose US, it proceeded. Can someone please look into this?

Thank you BKM, I will try doing that too and let you guys know if it solves the problem. I have a Core i5 Mac with an 8GB memory, and I am not sure if that should be the problem, but I will look into it.

For the time being, I am using a previous installation on a remote server and it’s working fine, but I should be able to install it on my system here.

I get this occasionally when I set up developer installs. My “solution” has been to open Firefox and Chrome at the same time and refresh the last step that fails in each browser until it completes the last step of the setup wizard and takes me to the desk. This happens to me on a Digital Ocean 2gb ram, 2 vcpu Ubuntu 16.04 droplet.