Error on ERPNext - Ubuntu 18.04 LTS Installation

Is there a work-around for this?

Can anyone point me toward a way to get this to work. I m not afraid to edit an installation file.


i did what muzzy suggested.
First i installed with the script got the errors, then removed main.yml as mentioned by Muzzy.
Then i manually installed Nodejs.
After that i used the file to install again. This time the install went through but there were still some complication so i did a “bench update” and it worked although i think i came across an npm yarn error and installed yarn manually as well but after that the “bench update” worked and my installs been running smoothly since yesterday.
Also you might have some issues doing the “bench update” if you are running a server with 1gb ram and 1gb swapfile like i am.

1 Like

Good scoop thanks! So Bitnami updates this to the current release, and kindly makes ova or vmdk images available to fetch ERPNext Virtual Machines

I suspect the ‘official’ image here is manually maintained and so can be ages out of date

Where do I find main.yml

When I get the error, I do not yet have a frappe-bench directory for the user.



the first time you use script it will store everything in tmp/.bench
you have to go to the directory i mentioned and remove the main.yml file

edit: you can also see the path of “tmp/.bench” when the fails


Thank you!!

1 Like


Welcome aboard !!!

You have been here only a short time and already you have added to the community.

Thank you immensely.

BKM :sunglasses:

i was big time lurking first VPS install i actually did was with your sudo -h technique so i jumped at the opportunity of helping you. i hope your install is up and running. They should sticky this topic.

It just completed successfully!!

Thank you again. I will post back here in a short while with the exact steps I used (including your work-around) to get to a successful system.


1 Like

i was planning to do that, but i trust you will do it better, as you have much more experience on here.

The browser that was using to create posts did not work well in the edit mode and it has created improper use of dashes in some of my posts. I have since re-edited this post with a different browser to fix this issue. I will not be using the conflicting browser in the future. Thank you to @jannis for pointing out the errors.

*EDIT Update *
This post has been updated to reflect additional steps needed after the successful completion of the install. These steps are important in order to get to the login page and start the system AFTER the install.

Ok, as promised, here are the steps I used to get the installation to complete on my Ubuntu 18.10 VPS host:

On a fresh Ubuntu host do the following:

  • Login as root and run the following commands:

apt-get update
apt-get upgrade

This will get the server up to the latest packages.

  • While still logged in as root, create the use r name account that you want to use for installing the ERPNext system (in my case it was “def_user”). then add then to the sudo group so they can execute commands without having to login as root user. Use these commands:

adduser [def_user]
usermod -aG sudo [def_user]

  • Then logout of the system and log back in as the new user

From there the following commands will get you a completed v12 install:

sudo -H apt-get install python3-minimal
sudo -H apt-get install python3-setuptools
sudo -H apt-get install build-essential
sudo -H apt-get install redis-server
sudo -H python3 --production --user [def_user]

At this point you will probably have encountered the error that ends with “exit status 2”

So do the following to complete the installation:

cd /tmp/.bench/playbooks/roles/nodejs/tasks
sudo mv main.yml main_yml.orig
cd ~
sudo apt-get install nodejs
sudo -H python3 --production --user [def_user]

This time your installation should complete without errors.
However, you are not yet finished. The next steps will get your system ready to login for the first time:

sudo npm install -g yarn
cd frappe-bench
bench update

At this point you are probably still waiting for the bench update to complete. It takes a long time because it rebuilds just about everything in the process. Once the bench update is done, you can open a browser and login to the system as the Administrator and let the startup wizard finish setting up the database and configuring the system for you.

One additional note…

The Setup Wizard that runs during your first Administrator login, will sometimes take to long to complete and it may timeout. If that happens, do not be alarmed, just click on the “Retry” link in the timeout message and it should be able to finish it’s work and get you into the system to start your work.

Hope this helps someone else. I was stuck for a while today. This may only be necessary for a short while as we hope the original playbooks problems are fixed soon.



Off topic

Did you know there’s directory stack commands available (if not pre-installed) for linux?

Instead of …

cd /tmp/.bench/playbooks/roles/nodejs/tasks
sudo mv main.yml main_yml.orig
cd ~
sudo apt-get install nodejs

… you can do …

pushd /tmp/.bench/playbooks/roles/nodejs/tasks
sudo mv main.yml main_yml.orig
sudo apt-get install nodejs
1 Like

Yup. I know they are available.

However, they do not exist by default is every VPS starting image. In fact sometimes there are simple things like some core python libraries that are also not included. Many of the VPS server images are minimalistic to allow the user to configure their OS for optimum performance and disk usage.

To that end, I always try to write my instructions with bash commands that are the most likely to be available to even the most minimal of systems. Otherwise I run the risk of alienating some of the newest users that might not have enough experience with Linux to know these things.

So, yes there are shortcuts, but I will ALWAYS default to the commands that I know should work without stranding the newbie user.

It is just good forum practice in my view.

Plus, trying to educate a newbie user on the concept of the stack is not the simplest thing in the world. That is why the original HP calculators were abandoned in the 1970’s. They were very efficient at their calculating abilities for complex equations, but people could not grasp the concept of the ordered stack. So the simple scientific calculator model was born.

BKM :grin:


1 Like

Yeah. I had TI-59. I didn’t care about math, but writing programs and saving on those magnetic strips – that was cool.

As usual, @bkm to the rescue!!! Everytime there’s an issue with installation you could always trust he would find a way out! Been relying on your installation solutions since v10!!! Thanks to your hardwork i can finally get my instance running after nearly two weeks of trying!

Thanks for the work you do bro! It’s much appreciated.

A little off topic, DigitalOcean essentially broke me today. They turned off my droplet cos of some “DDoS” attack coming from my droplet. I troubleshooted and couldn’t find any intrusion and they wouldn’t turn on my network so i could retrieve my data. Essentially lost one whole day of work. I had to create another instance using a backup 24 hours old. I’m dropping them and moving elsewhere.

Well, I appreciate the vote of confidence, but I was aided last night by some other knights in shining armor @MartinHBramwell and @warsmith

@warsmith was able to find the clues from a @Muzzy post that we needed to get this to work.

As for DO, I tried them once and found their customer service to be lacking. The service I use now is fairly quick to push issues up to the top problem solvers for me and I really appreciate them for it.

Good luck on your installs. :smiley:



This is my first support experience with them and it’s pretty awful. I’ll move over to another host over the weekend. But in the meantime, any tips on how i can set up hourly backup? I feel if i didn’t rely on daily backup i wouldn’t be in this mess.

Have you looked at this yet?

I use this to run an hourly backup of all data and and support files, then transmit them to both a second “hot spare” host and a storage host to keep multiple backups.

As for the rest of the server, I use a service that allows me to keep an image backup of a functioning server on hand. In the event of a disaster, I can open a ticket to have them restore the image to another server instance. Then I just restore one of my hourly data backups to be back online.

During the down time I just have the client switch their logins to the hot spare host until the primary host is rebuilt on new hardware.

So for example, if I have a primary host called then I would have a duplicate of that running all the time called that the users can log into in the event of a major disaster. The hot spare is never more than an hour behind.

Maybe you can do something similar.


I will defintely give this a try! Thanks a lot.

What service are you currently using? I’m still on DO and always looking for a better option also thanks for posting the backup tutorial.