Frappe Docker socketio in development

Socket is not working for development mode of frappe docker
How to enable it?

pull latest and try again

Rebuild the containers if using vs code

Not giving the socket error so I tried this tutorial but its not working

can you try that tutorial on non Docker bench and check if it works?

No I was never able to setup erpnext without docker as there always occurs an error on some point so I use docker

is it not possible to use socket in docker development?

I think the tutorial is not working on latest version.

Check how chat works if enabled on website from website settings.

ok let me check

Chat is not working on run time means socket must not be working

If I type it shows that other person is typing but message is not received unless I reload

I tried chat on /desk and it’s working without refresh.

with docker in development? But I have followed the exact steps of installation

see here I have to go back to see the message


when new bench is created it serves default site. sites/common_site_config.json has entry "serve_default_site": true, and also the file sites/currentsite.txt exists.

for the bench to serve multiple sites it needs minimum configuration changes after bench init is complete

try to set serve_default_site: false and delete sites/currentsite.txt

Ok I will try this tomorrow, also if possible add these instructions in the readme also so that other don’t get confused. Thankyou for helping.

Error that localhost does not exists

Pull latest image and rebuild containers

docker pull frappe/bench:latest

Also try doing normal bench start instead of attaching debugger and check if it works

Giving the same error, only works if currentsite.txt exists or is not empty

execute following command and then remove currentsite.txt

bench config serve_default_site off

This has nothing to do with Docker socketio in development. Start a new thread