Frappe v14 installation for development on MacOS using Docker - Help needed

I have been trying to install Frappe v14 on my macOS for following the tutorial. Initially, I tried the installation detailed here

I ran into a number of problems related to MariaDB - first to find the password and after I solved that, more and more problems on MariaDB. Frappe team recommended me to try the Docker route.

Then, in the past few days, I am trying to set up as per the instructions from the link latest recommended installation methods.

Once I land there, I faced this section which asked me to clone the frappe_docker repo and then cd into that. What to do afterwards was not mentioned there, even though the page says that the quick setup guide will be found below

Anyway, I clicked on the link provided there to frappe/frappe_docker: Docker images for production and development setups of the Frappe framework and ERPNext

Here it mentioned that you need docker, docker-compose and git - for basics of Docker, go to Docker site. Since I am totally new to Docker, I decided that I would spend the time to understand Docker first before proceeding with the installation. I have spent serious time trying to understand how docker and docker compose works - with that knowledge under my belt, I came back to this repo to see how to start the docker container.

Based on what I have learnt, I need to run docker compose up with the image. But I could not see any such instruction. Anyway, I tried it and I got the below error :slight_smile:

Ok - that did not work. I need to find a way to make this work. This page does NOT say anything about what to do after cloning the repo and cding into that folder.

So, I tried the link start development

Now this page again talks about setting up docker and docker-compose and adding user to Docker group (I did NOT know what that meant). It also talks about setting a higher RAM. I have done that.

Then, I followed the instruction given here, even though I could not understand why this was NOT done as part of the readymade repo - would have saved this trouble for many newbies like me.

Then it has asked me to install the Dev Containers Extensions - I did and followed all the steps. And this is the error I got:

I know this is VSCode error and not something to do with Frappe - I searched for an answer to this but could not find any answer. So, I reinstalled the extension, and the error is gone, but nothing really happens. I am gonna try reinstalling VSCode to see whether anything changes.

Meanwhile, can anyone help me with how to get the docker container running without using VSCode? And if anyone faced any similar problem on VScode, can you please point me to some resources?

Hi Siraj,

I have used the manual installation on MacOS on M2. It works nicely.
I have followed the steps listed on following link

You just have to be careful about the MariaDB version and its password. Everything else works well.

1 Like

Can you write down all steps?

Nitin, thanks for pitching in to help.

I have also followed the same steps, but got the errors about the MySQL password - i have posted about it here What is the Mysql default password? - #20 by Siraj_Samsudeen

When you say that we have to be careful, can you please explain what you mean?

Meanwhile, I have been able to get the Docker container running - I reinstalled VSCode and installed Docker extension inside VSCode as per the thread below (though it was about Windows OS) and this resolved the issue. Now, the Frappe container is starting inside VSCode…

Command ‘Remote-Containers: Reopen in Container’ resulted in an error (spawn …AppData\Local\Programs\Microsoft VS Code\wsl ENOENT) · Issue #3944 · microsoft/vscode-remote-release

Now that frappe container is running inside VSCode, I tried to do the next step - setup new bench.

When I ran the bash as per instructions, I got asked the name of the client. I don’t know what to enter - I entered frappe and even test and both failed saying no apps found. what should I enter for app name?

Hi @Nitin_Chintamani

Your help would be appreciated.

I stuck at the last step. facing flowing issue

supervisorctl restart frappe:
frappe: ERROR (no such group)
frappe: ERROR (no such group)
Traceback (most recent call last):
  File "/opt/homebrew/bin/bench", line 8, in <module>
  File "/opt/homebrew/lib/python3.10/site-packages/bench/", line 127, in cli
  File "/opt/homebrew/lib/python3.10/site-packages/click/", line 1130, in __call__
    return self.main(*args, **kwargs)
  File "/opt/homebrew/lib/python3.10/site-packages/click/", line 1055, in main
    rv = self.invoke(ctx)
  File "/opt/homebrew/lib/python3.10/site-packages/click/", line 1657, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/opt/homebrew/lib/python3.10/site-packages/click/", line 1404, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/opt/homebrew/lib/python3.10/site-packages/click/", line 760, in invoke
    return __callback(*args, **kwargs)
  File "/opt/homebrew/lib/python3.10/site-packages/bench/commands/", line 59, in update
  File "/opt/homebrew/lib/python3.10/site-packages/bench/utils/", line 456, in update
    bench.reload(web=False, supervisor=restart_supervisor, systemd=restart_systemd)
  File "/opt/homebrew/lib/python3.10/site-packages/bench/utils/", line 126, in wrapper_fn
    return fn(*args, **kwargs)
  File "/opt/homebrew/lib/python3.10/site-packages/bench/", line 151, in reload
    restart_supervisor_processes(, web_workers=web)
  File "/opt/homebrew/lib/python3.10/site-packages/bench/utils/", line 315, in restart_supervisor_processes"{sudo}supervisorctl restart {group}")
  File "/opt/homebrew/lib/python3.10/site-packages/bench/", line 48, in run
    return exec_cmd(cmd, cwd=cwd or self.cwd)
  File "/opt/homebrew/lib/python3.10/site-packages/bench/utils/", line 158, in exec_cmd
    raise CommandFailedError
kashif@kashifs-air frappe-bench1 % 

Hey Nitin ,
Could you please make a detailed instructions notes or perhaps a video(much appreciated) to ensure proper installation and deployment of frappe and ERPNext in MacOS (Silicon Chips).
As nowhere to be found for these platform.
Thank you.