Hide/show modules on desktop

I have a strange problem; if I hide a module on the desktop, it disappears, but I can never show it again! (once hidden, always hidden!)
But if another user, in the same system hides a module, he can show it again as normal!

we have exactly the same rights and settings. why could that be?

(frappe 12.1.6, Erpnext 12.0.16)


Anyone else has the same problem, or an idea why it is so?

1 Like

hi, I have problem with shortcuts on the desktop, if I hide all shortcuts I can’t bring it back. there’s no option to do that.

1 Like

Do you have this issue also?

yes, I have it.

1 Like

I have had that problem in early versions of v12. Now it seems to have been fixed. I cant seem to reproduce it. And I dont know what I did to fix it.

1 Like

I‘ve got frappe 12.1.6 and erpnext 12.0.16 and still got the issue :thinking:

So i dont belive its fixed

I have same version:

ERPNext: v12.1.6 (version-12)
Frappe Framework: v12.0.16 (version-12)

1 Like

Installed Apps
ERPNext: v12.0.8 (version-12)

Frappe Framework: v12.0.8 (version-12)

So it seems the issue has come with the newer version :thinking:

Was my first thought. I think it went away and then came back.

1 Like

do you have any ideas to find the cause?
Search on change history of github? :thinking:

I do not even have an error message that I could track :sweat_smile:

The day I get great at GIT, I will start coding like hell… :slight_smile: so sorry to disappoint you.

1 Like

Have you checked if it is language related? In EN it seems to work better, the issue seems to affect mostly other languages such as DE…

Ok, here is what I found about hide/show cards.
It doesnt work well (or work consistently) when I log in as ADMINISTRATOR.
But any other user, it works as expected. I havent tried other languages.

Any update on this? We still see the fact that cards that are hidden will not show up again even if they are checked on the “sho/hide cards” dialog. Deleting the Settings > Home Settings string does not revert this, pasting a functional string also has no impact…

We have one user who cannot see module on desktop even though enabled - whereas other can see it… Desktop takes 15 seconds to load after clearing cache. Each module takes 3 seconds to load after clicking on card. Any advice on how to troubleshoot? Using V12.1.8 with Python3.6

Dear colleagues,

any update on this? While we cannot strictly reproduce it, it still happens that a user hides a card and when he later tries to show it again it will not show up (not always…!). Changing the allowed modules section of the user has no effect, neither has flushing the cache (neither browser nor bench clear-cache)…

So, this turned out to be an issue in handling the Redis cache. While we cannot fully reproduce it, it happens often. Resetting the “home_settings” on the user has no effect (as it is cached and the cache will overwrite the settings).

As a workaround to at least get all cards back on:

  • go to user settings and clear “home_settings”
  • overwrite the cache with the current home_settings

Any solution for this ?

1 Like