How to increase 'worker' timeout time?

I’ve read all the threads about increasing the number of workers.

How can increase their timeout setting?

Hi Martin,

That setting is here I think

frappe@ubuntu:~/frappe-bench$ grep gunicorn config/supervisor.conf
command=/home/frappe/frappe-bench/env/bin/gunicorn -b -w 1 -t 120 --preload

This docs gunicorn timeout Settings — Gunicorn 21.2.0 documentation

Here trentmu notes a timeout from say a circular reference in a BOM tree Worker timeout (Stock Entry/transfer on Production Orders)

1 Like