How to installl a module

I have setup manually and installed new site with profile manufacturing but the manufacturing module is not available.

How can i install the module ?

Hope help full for you

1 Like

Thanks for the reply.I tried this way already but not able to solve the issue

The manufacturing module .is built into ERPNext in the Manufacturing Domain. Manufacturing should show up as a box in your Desk. This is where you issue your BOMs other tasks. Try opening the Company and select Manufacturing in the Domain input.

The previous reply is not related to your question. Process Manufacturing is one which produces many processed products from raw maturials. In ERPNext, Manufacturing prouces one product (and scrap) from raw materials. So, if you are familiar with Frappe, you can make your own module and install it to ERPNext to add to ERPNext capabilities. This is the advantage of ERPNext being open source.

In desk manufacturing module was invisible/hidden, but i can be able to see it in user page for assigning permission(s) example Manufacturing User

Check out this link. You will learn how to turn on the Manufacturing Domain.

The problem was when i setup new site that time i chose manufacturing domain, but there was problem in the setup wizard it failed and while retry setup it didn’t show the manufacturing module/domain.

even though, i didn’t chose manufacturing domain it got timed out and not able to see manufacturing module in the settings after setup completed

Your installation is broken.
Its better you clean start using bench easy install method.

i think problem is with

when i download it and try to install using
sudo -H python3 --production --site localhost --user erpnext --mysql-root-password your_password --admin-password your_password --bench-name your_bench_name

i got this issue

Note: I tried with new servers every time and the result is same for every new instance

This is a condition that usually occurs when we install in low-end setups (like 4G memory and 2 CPU virtualbox). You just retry and retry until you reach the desk. I don’t think your installation is broken.

yeah. i retried but it shows all the modules except manufacturing

if you are familiar with docker then give a try to

I checked the Manufacturing checkbox in the Domain Settings and went back to Desk. I refreshed the browser, and the Manufacturing box under Domain was shown. This means that ERPNext is okay.


Then, I deleted the existing default Company and unchecked the Manufacturing option in Domain Settings.

Then I entered a new Company with another name.

I checked the Manufacturing option in the Domain Setting and noted that I could not save the Domain Setting because the system complained that the Default Warehouse (showing the warehouse name of the deleted company) does not exist, I went to Stock Settings and changed the Default Warehouse to the one that belongs to the new (current) Company. Then I went back to Domain Setting, checked the Manufacturing Option, clicked Save button, clicked ERPNext Logo to go to Desk. Refresh browser, the the Manufacturing Option is shown.

Can you check if the Default Warehouse in your Stock Setting is a valid choice?

I am having a very similar issue. I have just logged into the new site I built and no domains are visible.

In terms of server - brand new Dell 32 GB RAM with dual CPUs. There were no errors while building the site.

If you recommend for me to start with a clean build, what is the bench site to remove the existing sites?

Thank you

So, I had followed the directions in the github forum pretty well I felt. However, I missed once the server comes up the first time on port 8001 - do your first setup.

I deleted everything in the erp home directory and dropped the database and reinstalled. All is well now.