@ in comments (Supplier info) caused "Encryption key is invalid, Please check site_config.json"

I was in the process of updating Suppliers - adding comments relating to delivery costs etc. Almost all went through perfectly, but there was 1 that contained
“20kgs @ 5100 p/kg”
This caused “Encryption key is invalid, Please check site_config.json” (I obviously had not made any changes to that file).

I edited to “20kgs at 5100 p/kg” - and then it went through without any trouble.
I did check the charset etc and there seems to be nothing in there which would cause an issue.

I also tried to create a comment which contained ONLY
Same error occurred (implies some sort of escaping is needed?? but I am not a programmer :blush:

On the other side of the spectrum, including an email address in the comments seems to be OK - it’s just when the character is between whitespaces that it isn’t happy

  • Is this a normal/expected behaviour?
  • The “problem” is solved - but I am just curious
1 Like

for now try using a \ before (i.e. \@)and see what happens (I would test it myself but my ERPNext instance is currently down).

Added the , but same result. So items that fail…
BUT… a@a works fine