Install Error (errors repeated exactly 3x)

Linode 2GB Ubuntu 14.04 hardened with Firewall & Fail2Ban

Immediately following I ran:

sudo bash --setup-production

And the installation script throws the following errors: erpnext /home/admin/frappe-bench/env/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see SNIMissingWarning /home/admin/frappe-bench/env/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see InsecurePlatformWarning /bin/sh: 1: npm: not found installing frappe installing erpnext Traceback (most recent call last): File "/usr/local/bin/bench", line 9, in load_entry_point('bench==3.0.0', 'console_scripts', 'bench')() File "/home/admin/bench-repo/bench/", line 40, in cli bench_command() File "/usr/local/lib/python2.7/dist-packages/click/", line 716, in __call__ return self.main(*args, **kwargs) File "/usr/local/lib/python2.7/dist-packages/click/", line 696, in main rv = self.invoke(ctx) File "/usr/local/lib/python2.7/dist-packages/click/", line 1060, in invoke return _process_result(sub_ctx.command.invoke(sub_ctx)) File "/usr/local/lib/python2.7/dist-packages/click/", line 889, in invoke return ctx.invoke(self.callback, **ctx.params) File "/usr/local/lib/python2.7/dist-packages/click/", line 534, in invoke return callback(*args, **kwargs) File "/home/admin/bench-repo/bench/commands/", line 17, in init no_auto_update=no_auto_update, frappe_path=frappe_path, frappe_branch=frappe_branch, verbose=verbose) File "/home/admin/bench-repo/bench/", line 69, in init setup_socketio(bench=path) File "/home/admin/bench-repo/bench/", line 109, in setup_socketio exec_cmd("npm install redis express superagent cookie", cwd=bench) File "/home/admin/bench-repo/bench/", line 99, in exec_cmd raise CommandFailedError(cmd) bench.utils.CommandFailedError: npm install redis express superagent cookie

I read online here to ignore SNIMissingWarning & InsecurePlatformWarning. Next up is /bin/sh: 1: npm and bench.utils.CommandFailedError: npm install redis express superagent cookie. I searched here and online and couldn’t come up with anything, so I rebuilt the server and tried two additional attempts which resulted in the exact same errors. I haven’t been working with ERPnext for about a year, but I had assumed the install script had been nailed down. Any ideas on where to go from here? Is there an install log? I looked but couldn’t find one.

I appreciate any help or ideas where to look. I have a new ERP client very interested and if they select ERPnext, it’ll be a good size deal for all involved.


Obviously /home/admin/frappe-bench/logs is empty. So this post didn’t provide any clues:


And here’s the solution:


First uninstall:
sudo apt-get purge nodejs npm

Then enable nodesource’s repo and install (obviously curl needs to be installed):

curl -sL | sudo bash -
sudo apt-get install -y nodejs

Then run sudo bench setup socketio

Mods, please close topic if you’d like.

1 Like