Installation instructions are outdated


i want to install Frappe Framework only, and i followed the official installation instruction, but i get error on every step, instructions are outdated and not clear, it should be rewritten.

does any of you have a clear installation instruction?


If you need a development environment, check out ‘GitHub - rtCamp/Frappe-Manager: A CLI tool based on Docker Compose to easily manage Frappe based projects.’. It makes installing Frappe very easy!

Hey there, Meraki,

So - For myself, I don’t have an IT background at all. I feel like I can relate to your frustration.

In my case, doing a walk-through with the course available on Frappe School really helped me out.

I would suggest it for you as well - That is if installing locally is okay for you.

Also - could you advise some details about your setup? That would help someone to troubleshoot or give more advice.

Hi @gopikrishnan,
Thank you for reply, i will try that.

Edit: i checked that and i realized i tried it before, but it is on docker, which i dont have experience so i did not like it.

Hi @1coconut,

Thank you for reply, i was trying to install on ubuntu 22.04 on virtual machine.
I followed the official installation instruction on

Just follow the steps and try the install v15, you will see.

I will check frappe school for that, thanks.

Sorry for the late response, Friend -


I’m currently on Debian 12 “Bookworm”. I was able to get Frappe 15.14.0 Installed successfully, and have only frappe builder as the current site.

I work full-time as Insurance sales and am in University at this moment so I haven’t dedicated much time yet - but rest assured if you walk through the tutorial you will get it.

I will note that I updated a lot of the “back-end” services namely:

  • Python 3.11.2 (Dev)
  • Node.JS 18.19.0
  • MariaDB 10.11.6
  • Redis 7.0.15
  • Yarn 1.22.21
  • Pip 23.0.1

Thank you for your reply i am late too, because i am working on different subject as well, i followed official instruction, at first python installation failed so i installed python3 but instruction stated to install python only, not giving any version, so then installed other packages with the version which supports python3 like Node.JS 18.19.0 (like you). at the end everything seems ok but cannot access to UI. i will try today or tomorrow maybe, i will write the result.


i followed official instruction again and failed again;

Below i chose to install V15

instead given code i used sudo apt install git python3-dev python3-pip redis-server as in history (8) (given at the end of the post)

i did not use this because my version is 22.04

secure installation doesn’t work without sudo and there is no mariadb-client-10.3 since latest mariadb is installed (10.6) client must be 10.6 too.

at the beginning we chose to install V15 so we should install Node.JS 18 but you cannot install with given code, so from this url; GitHub - nvm-sh/nvm: Node Version Manager - POSIX-compliant bash script to manage multiple active node.js versions we get correct installation url but after installation npm doesnt work, to make it work, you have to run one of them below which suits you best;

bash: source ~/.bashrc
zsh: source ~/.zshrc
ksh: . ~/.profile

if you follow this you will get dependency error, but you have to, so you should use sudo apt-get -f install (48)

bench command doesn’t work you have to add it to path (50-51)

bench init frappe-bench doesn’t work you have to install sudo apt install python3.10-venv (58)

After solving everything i can not access to site because i didnot created an app or site, but when i tried to create an app i had supervisor error i could not fix it so i quit.


Sorry i had to green out some information

History of commands;

 2  sudo apt upgrade
 3  sudo apt update
 4  sudo apt upgrade -y
 5  init 6
 6  sudo init 6
 7  sudo apt install git python3.11-dev python3.11-pip redis-server
 8  sudo apt install git python3-dev python3-pip redis-server
 9  python3 -V
10  sudo apt install software-properties-common
11  sudo apt-get update
12  sudo apt-get install mariadb-server
13  celar
14  clear
15  mysql_secure_installation
16  clear
17  paswwd root
18  passwd root
19  sudo passwd root
20  clear
21  mysql_secure_installation
22  clear
23  mysql_secure_installation
24  sudo mysql_secure_installation
25  apt-get install mariadb-client-10.6
26  sudo apt-get install mariadb-client-10.6
27  sudo nano /etc/mysql/my.cnf
28  curl -o- | bash
29  nvm install 18
30  source ~/.bashrc
31  nvm install 18
32  node -v
33  npm install -g yarn
34  npm install -g npm@10.7.0
35  npm fund
36  npm update
37  npm fund
38  npm fund
39  apt-get install xvfb libfontconfig
40  sudo apt-get install xvfb libfontconfig
41  curl -o-
42  ls
43  wget
44  sudo dpkg -i wkhtmltox_0.12.6.1-2.jammy_amd64.deb
45  sudp apt install -f
46  sudp apt -f instal
47  sudp apt -f install
48  sudo apt-get -f install
49  pip3 install frappe-bench
50  PATH=$PATH:/home/${user}/.local/bin
51  export PATH
52  ls
53  bench --version
54  cd ~
55  bench init frappe-bench
56  sudo bench init frappe-bench
57  python3 -V
58  apt install python3.10-venv
59  sudo apt install python3.10-venv
60  bench init frappe-bench
61  ls
62  cd frappe-bench/
63  bench start
64  bench find .
65  bench new-app library_management

Hi @meraki you can try this easy install script on Ubuntu 20.04 or Ubuntu 22.04. GitHub - flexcomng/erpnext_quick_install: Unattended install script for ERPNext Versions, 13, 14 and 15

It doesn’t require any installation knowledge and only minimal input required and handles everything.

thank you for reply, i know your script and i used it many times, thank you for such a great work.
But i want to install Frappe framework only, i don’t want to install ERPNext or any other app, just Frappe framework.

@meraki you can edit the script and remove the flags --install-app erpnext This will install frappe framework only.

i am not sure if i can do it, is it enough to delete ERPNext installation flag?

@meraki Yes. i have done it multiple times. The flag just tells the script to add ERPNext as part of the site install but if you remove it, ERPNext will not be installed only Frappe. to be specific:

This line:

bench init frappe-bench --version $bench_version --verbose --install-app erpnext --version $bench_version

change to:

bench init frappe-bench --version $bench_version --verbose

and this line

bench new-site $site_name --db-root-password $sqlpasswrd --admin-password $adminpasswrd --install-app erpnext

change to:

bench new-site $site_name --db-root-password $sqlpasswrd --admin-password $adminpasswrd



I will definitely try this.

Thank you.

let me know if it works

Hi @rmehta, @umair,

some instructions are outdated or very confusing like the one we discussed here.

i will.

it worked like a charm.
thank you for this great script.

as a suggestion you may ask user to whether continue to install ERPNext or not, or maybe you may ask at the beginning.

1 Like

This is a good suggestion. I will look at including this as additional question to give the user the option to install ERPNext as part of the installation process.


How do we give you money to ensure you keep that script updated? :wink:

Please, please, 5 years from now still be here. <3