Installing and configuring ERPNext production on Ubuntu 16.04.1 server?

im beginner on ERPNext, i want to know how to install ERPNext on ubuntu 16.04.1 server?
i tried many times before to following instruction from GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps but i steel have an error msg when i was run sudo python --production , the error is:

1 Like did not download correctly!

1 Like

Make sure you are root

sudo su - root

and then make sure you download the install file right. Best to use wget


then still as root

python ./ --production


There’s something with 16.04 causes such services does not start at boot
login page showing, something went wrong, it is not you, it is us, back soon

1 Like

OK think you

when this wrong will be corrected, can you tell me plz??

Wooo! this just worked after a million tries of other guides

Thanks James, I tried a million other guides before

1 Like

Glad it worked for you.

1 Like

Thanks. I’m having some trouble executing my bench commands:

Root says use non root user (frappe)

Frappe says permission denied:

  1. frappe@ip-172-31-22-170:/root$ bench get-app erpnext GitHub - frappe/erpnext: Free and Open Source Enterprise Resource Planning (ERP)
  2. app erpnext
  3. Traceback (most recent call last):
  4. File “/usr/local/bin/bench”, line 11, in
  5. load_entry_point('bench', 'console_scripts', 'bench')()
  6. File “/home/frappe/.bench/bench/”, line 40, in cli
  7. bench_command()
  8. File “/usr/local/lib/python2.7/dist-packages/click/”, line 722, in call
  9. return self.main(*args, **kwargs)
  10. File “/usr/local/lib/python2.7/dist-packages/click/”, line 697, in main
  11. rv = self.invoke(ctx)
  12. File “/usr/local/lib/python2.7/dist-packages/click/”, line 1066, in invoke
  13. return _process_result(sub_ctx.command.invoke(sub_ctx))
  14. File “/usr/local/lib/python2.7/dist-packages/click/”, line 895, in invoke
  15. return ctx.invoke(self.callback, **ctx.params)
  16. File “/usr/local/lib/python2.7/dist-packages/click/”, line 535, in invoke
  17. return callback(*args, **kwargs)
  18. File “/home/frappe/.bench/bench/commands/”, line 30, in get_app
  19. get_app(git_url, branch=branch)
  20. File “/home/frappe/.bench/bench/”, line 55, in get_app
  21. shallow_clone = '--depth 1' if check_git_for_shallow_clone() else ''
  22. File “/home/frappe/.bench/bench/”, line 314, in check_git_for_shallow_clone
  23. git_version = get_git_version()
  24. File “/home/frappe/.bench/bench/”, line 305, in get_git_version
  25. version = get_cmd_output("git --version").strip().split()[2]
  26. File “/home/frappe/.bench/bench/”, line 321, in get_cmd_output
  27. return subprocess.check_output(cmd, cwd=cwd, shell=True, stderr=open(os.devnull, 'wb')).strip()
  28. File “/usr/lib/python2.7/”, line 567, in check_output
  29. process = Popen(stdout=PIPE, *popenargs, **kwargs)
  30. File “/usr/lib/python2.7/”, line 711, in init
  31. errread, errwrite)
  32. File “/usr/lib/python2.7/”, line 1343, in _execute_child
  33. raise child_exception
  34. OSError: [Errno 13] Permission denied: ‘.’

Any ideas how to proceed?

got it

cd into frappe-bench to setup the site

This will explain a bit for you: