Issue in Email Account

Hi all,

When I try to set a new Email Account for both Default Sending and Inbox in a Gmail domain, It takes a long time to save the document and getting a error like below.

Here is a screenshots. Kindly any one help me .

This could possibly be some issue with the Database. Check console, stack trace would have been there.

Have you checked your server’s performance ?

Hi @root13F

Here is a screenshot and console stack trace.

Unable to handle failed response
desk.min.js?ver=1524590404.0:1594 TypeError: Cannot read property ‘exc’ of undefined
at after_save (form.min.js?ver=1524590404.0:711)
at Object.error [as error_callback] (form.min.js?ver=1524590404.0:2348)
at _ (desk.min.js?ver=1524590404.0:1532)
at Object. (desk.min.js?ver=1524590404.0:1588)
at i (jquery.min.js:2)
at Object.fireWith [as rejectWith] (jquery.min.js:2)
at z (jquery.min.js:4)
at XMLHttpRequest. (jquery.min.js:4)
(anonymous) @ desk.min.js?ver=1524590404.0:1594
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
z @ jquery.min.js:4
(anonymous) @ jquery.min.js:4
load (async)
send @ jquery.min.js:4
ajax @ jquery.min.js:4 @ desk.min.js?ver=1524590404.0:1548 @ desk.min.js?ver=1524590404.0:1441
_call @ form.min.js?ver=1524590404.0:2485
save @ form.min.js?ver=1524590404.0:2340 @ form.min.js?ver=1524590404.0:2511
(anonymous) @ form.min.js?ver=1524590404.0:747
Promise.then (async)
(anonymous) @ desk.min.js?ver=1524590404.0:675
frappe.run_serially @ desk.min.js?ver=1524590404.0:673
_f.Frm._save @ form.min.js?ver=1524590404.0:737
(anonymous) @ form.min.js?
setTimeout (async)
(anonymous) @ form.min.js?ver=1524590404.0:694 @ form.min.js?ver=1524590404.0:688
Save @ form.min.js?ver=1524590404.0:1777
(anonymous) @ desk.min.js?ver=1524590404.0:3195
dispatch @ jquery.min.js:3
$event.dispatch @ report.min.js?ver=1524590404.0:3022
r.handle @ jquery.min.js:3

Hi @Racer_Aravind
Seems like some network related issue on your server. Check the following article to find the ways to fix this

1 Like

Hi @ManasSolanki,

Only if I uncheck the Awaiting Password and entered the password, I am getting a Request time out message.
There is no internet and network issue because I could do other activities like Purchase order, Sales Invoice without any error.

“gmail will only work if you allow access for less secure apps in Gmail settings”

Have you eliminated this as maybe the source of your problem?

A search on ‘gmail setup’ or similar will take you to much advice on this.

1 Like

@clarkej is right. I have gotten dozens of those errors as I have tried to get email going and (for me) it has always indicated an configuration error.

1 Like

Hi @clarkej,

I have enabled access for less secure apps, here is a screenshot. Still getting the same issue.

The setting that finally worked for me (and I am using my own server, not Gmail) was “Always use Account’s Email Address as Sender”. I set this to On/Yes and got things going. Sorry that I don’t have more help to offer.

ok and have you resolved whether gmail requires you to generate and use an app password? Sign in with App Passwords - Google Account Help

Also you must identify what port the service you wish to connect to and runs on, and ensure that port is open That typically is the cause of a failed connection timeout.

We found something weird when we were on a google server and had to use the alternate STMP port number 2526. (this is apparently because 587 is reserved for Gmail.) Here’s a list of ports to try.

Please tell me exactly how to solve this. Anyone kindly help me.


“Please tell me exactly how to solve this. Anyone kindly help me.”

How to solve exactly what? Exactly what you have tried, what steps?

Hi @clarkej,

I have enabled the access for less secure apps in Gmail Settings and used port 587, SMTP server as and enabled the Default Outgoing option and try to save the document. But still getting request timed out error.


Did you identify your issue a closed port as suspected? [v10] Request Timed Out for email