NOT PERMITTED [Session expired. Logging you out]

This is week 2 of evaluating ERPNext on-site production installation. Things have been almost smooth so far it it wasn’t for the usual Exceptions in the Communications, a few in the modules (Accounts), and at worst Internal Server Errors, only resolved by a server reboot (in my limited knowledge).

But right now I have a funny issue. 4 out of 5 users can not login, after login we automatically out with following Modal error:

Not Permitted

Session expired. Logging you out

You do not have enough permissions to access this resource. Please contact your manager to get access.

The facts are:

  1. I am the original user with full access, until now
  2. I can access the system on the android app without issues
  3. There’s another user who, when he logs in is given access to my account instead of his own until he is logged out. Which is why I suspect a session mismatch.
  4. Sessions are set to expire after 24hrs
  5. 5 and 20 concurrent sessions respectively are allowed for the two users in question
  6. One user out of all has no issues at all
  7. A server restart wont resolve the problem
  8. Hard reload, and cache clearance wont resolve the problem
  9. Latest bench, frappe, and ERPNext (7) are installed

I think its a Login/Session mismatch/misconfiguration issue. I would appreciate some help at this point. I don’t mind doing a server re-installation. As long as I can restore from my backups.


UPDATE 24/01/16 2.26PM

  • All users are unable to login. Same error.

@adam26d there will soon be an Authentication Log to help you with login issues

1 Like

Yeah. I’ve been able to see a feed of users login and out. I don’t think mine is a login issue. Sessions must be mis-assigned.

Any ideas how I can resolve my issue ?

This could have solved it (still observing):

The problem is back :frowning:

Hi how did you finally resolve this?


Weirdly I never solved it. It just never came back after a few setups. A common variable is that I was using AWS.

Where’s the authentication log? I don’t see it anymore