Outgoing emails through Amazon SES

Hi there,
I am trying to setup email addresses using Amazon SES.
email: sales@example.com
incoming server: mail.example.com
outgoing server: email-smtp.us-west-2.amazonaws.com

When i add an email address i have no problem to specify incoming username and password.
But when it comes to setup outgoing server i can only setup server name, and port.
Where i can setup my username and password (that are different than incoming user and password) ?

Hi @fromthestone

check the option 'Use Different Email Login ID'. You’ll then have another field appear for your username


I have set up differently:
I share it because can be useful also for other users

I assume that on Amazon SES you already configured everything

Go in /etc/postfix and add in main.cf:

relayhost = [email-smtp.us-west-2.amazonaws.com]:587
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_use_tls = yes
smtp_tls_security_level = encrypt
smtp_tls_note_starttls_offer = yes
default_transport = smtp
relay_transport = smtp
smtpd_sasl_type = cyrus
cyrus_sasl_config_path = /etc/postfix/

Create the file sasl_passwd with username and password:

[email-smtp.us-west-2.amazonaws.com]:587       username:password

Create the db file:
postmap /etc/postfix/sasl_passwd

Change permissions
chown 640 /etc/posfix/sasl_passwd*

Restart postfix
systemctl reload postfix

Now you can use localhost in your ERPNext domain configuration for outgoing emails :slight_smile:



Thanks for sharing this @fromthestone. I have setup a postfix relay and everything tests well from the command line. However, when setting the Domain in ERPNext i get an “Outgoing email account not correct”. Can you please post how you setup the domain in ERPNext?

I seemed to have resolved the issue. These are the settings used:

1 Like