Production Installation Failure on Ubuntu Server 16 LTS ( info_egg )

First posted on github bench issues - Issue easy installing bench for production on an EC2 - ubuntu 16.04 (64bit) instance · Issue #327 · frappe/bench · GitHub

I’ve been trying to setup ERPNext on EC2 for 2 days now, after over 10 attempts on freshly installed OS, 0 success!

I’ve tried different PHP versions, PIP addons (setuptools), python-mysqldb setup, etc on Ubuntu 14 and Ubuntu 16.

I’ve also tried

  1. Kitty’s guide, but it leads me to an installation which wont authenticate the admin - [AMAZON EC2] Installation Step by Step Tutorial - #3 by deepti

  2. The devvelop version

  3. Both manual, and script aided install attempts

On GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps

I cant get past the frappe installation.
The easy setup script is getting stuck at with a the error:
no hosts available related to ansibleRelated to issue #336
While the manual setup is failing at the error:
Command “python egg_info” failed with error code 1 in /tmp/pip-build-e8Q0ZW/mysql-python/
frappe@ip-172-31-21-146:~$ bench init frappe-bench &&
cd frappe-bench Already using interpreter /usr/bin/python app frappe Cloning into ‘frappe’… remote:
Counting objects: 1979, done. remote: Compressing objects: 100%
(1829/1829), done. remote: Total 1979 (delta 269), reused 771 (delta
95), pack-reused 0 Receiving objects: 100% (1979/1979), 12.59 MiB | 3.65
MiB/s, done. Resolving deltas: 100% (269/269), done. Checking
connectivity… done. installing frappe frappe
Command “python egg_info” failed with error code 1 in
/tmp/pip-build-iwmeai/mysql-python/ Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)() File
“/home/frappe/bench-repo/bench/”, line 40, in cli bench_command()
File “/usr/local/lib/python2.7/dist-packages/click/”, line 722,
in call return self.main(*args, **kwargs) File
“/usr/local/lib/python2.7/dist-packages/click/”, line 697, in
main rv = self.invoke(ctx) File
“/usr/local/lib/python2.7/dist-packages/click/”, line 1066, in
invoke return _process_result(sub_ctx.command.invoke(sub_ctx)) File
“/usr/local/lib/python2.7/dist-packages/click/”, line 895, in
invoke return ctx.invoke(self.callback, **ctx.params) File
“/usr/local/lib/python2.7/dist-packages/click/”, line 535, in
invoke return callback(*args, **kwargs) File
“/home/frappe/bench-repo/bench/commands/”, line 19, in init
verbose=verbose, clone_from=clone_from) File
“/home/frappe/bench-repo/bench/”, line 56, in init
get_app(frappe_path, branch=frappe_branch, bench_path=path,
build_asset_files=False, verbose=verbose) File
“/home/frappe/bench-repo/bench/”, line 73, in get_app
install_app(app=app_name, bench_path=bench_path, verbose=verbose) File
“/home/frappe/bench-repo/bench/”, line 103, in install_app
find_links=find_links)) File “/home/frappe/bench-repo/bench/”,
line 127, in exec_cmd raise CommandFailedError(cmd)
bench.utils.CommandFailedError: frappe-bench/env/bin/pip install -q -e
frappe-bench/apps/frappe frappe@ip-172-31-21-146:~$ copying
setuptools/ → build/lib.linux-x86_64-2.7/setuptoo

    Attach files by dragging & dropping,
    , or pasting
    from the clipboard.


    Styling with Markdown is supported

This guide just helped me past these issues.