Sales/purchase order list wont load

I have just done a fresh installation of ERPNext on my ubuntu 14.04. When I go to Selling and click on Sales Order the screen just get blur and I have to reload after going to the Home page. Same happens in the case of purchase order. I am still able to make a new sale/purchase order through the navigation bar or from a quotation etc. The screen shots are as below

Same thing happens when I click Journal Entry in Accounts.
Kindly Help

can you please try to update your bench and try again…

bench update
bench migrate

if its still not working try to press the reload button in the user menu and reply back with result please…

Thank you for addressing the issue. I have applied both:

  1. Bench Update
  2. Bench Migrate

The problem still persists. I have to go back to and then press reload button in the user menu to make things back to normal. I explored the ERPNext and found out the following pages make ERPNext freeze as I click them.

—> Sales Invoice
—> Purchase Invoice
—> Journal Entry

—> Delivery Note
—> Serial No Warranty Expiry


—> Sales Order

—> Purchase Order
—> Supplier Quotation

—> Leave application

—> Production Order

—>Maintenance Visit
—>Maintenance Schedule

I have the same issue…

New install this morning on Ubuntu 14.04…

Am very happy to see a post already listed relating to this problem. I have run Bench Update and Bench migrate. details below:

tractorparts@TRACTORPARTS:~$ bench update

INFO:bench.utils:updating bench
Already up-to-date.
Requirement already satisfied (use --upgrade to upgrade): Pillow in ./env/lib/python2.7/site-packages frappe
From GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript

  • branch master → FETCH_HEAD
    Already up-to-date. erpnext
    From GitHub - frappe/erpnext: Free and Open Source Enterprise Resource Planning (ERP)
  • branch master → FETCH_HEAD
    Already up-to-date.
    /home/tractorparts/frappe-bench/env/local/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see
    /home/tractorparts/frappe-bench/env/local/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see
    Requirement already up-to-date: pip in ./env/lib/python2.7/site-packages
    Migrating site1.local
    Updating frappe : [========================================]
    Updating erpnext : [========================================]
    Wrote ./assets/js/print_format_v3.min.js - 18k
    Wrote ./assets/js/frappe-web.min.js - 101k
    Wrote ./assets/js/form.min.js - 113k
    Wrote ./assets/js/report.min.js - 157k
    Wrote ./assets/js/erpnext.min.js - 36k
    Wrote ./assets/css/list.min.css - 6k
    Wrote ./assets/js/erpnext-web.min.js - 1k
    Wrote ./assets/css/report.min.css - 7k
    Wrote ./assets/css/frappe-web.css - 51k
    Wrote ./assets/js/list.min.js - 66k
    Wrote ./assets/js/dialog.min.js - 58k
    Wrote ./assets/js/desk.min.js - 874k
    Wrote ./assets/css/form.min.css - 2k
    Wrote ./assets/js/editor.min.js - 26k
    Wrote ./assets/css/erpnext.css - 1k
    Wrote ./assets/css/desk.min.css - 256k
    Wrote ./assets/css/module.min.css - 2k
    frappe-bench-node-socketio: stopped
    frappe-bench-frappe-web: stopped
    frappe-bench-frappe-async-worker: stopped
    frappe-bench-frappe-longjob-worker: stopped
    frappe-bench-frappe-workerbeat: stopped
    frappe-bench-frappe-worker: stopped
    frappe-bench-node-socketio: started
    frappe-bench-frappe-web: started
    frappe-bench-frappe-async-worker: started
    frappe-bench-frappe-longjob-worker: started
    frappe-bench-frappe-workerbeat: started
    frappe-bench-frappe-worker: started

Bench: Open source installer + admin for Frappe and ERPNext (

tractorparts@TRACTORPARTS:~$ bench migrate
Migrating site1.local
Updating frappe : [========================================]
Updating erpnext : [========================================]

Hi @ramielian and @rushabh_mehta any ideas with this one?

Would love to have this resolved if poss?

Many thanks


Am sorry for late replies but am on a business trip…

@PaulTheTrouble can you try:
Bench setup scheduler
Bench use site yoursitename
Bench enable scheduler

Then try again and please feedback

@vjFaLk this problem we discussed about earlier in the form… I think there is a function as I remember to trigger the bench reload when loading a screen which is now not working automatically…

Also the same problem with dropbox backups and some email times email digest…

Isn’t it all manager by superviser or scheduler to trigger it ?

hey @ramielian I am grateful for any replies, much appreciated.

Attempting to run the above on MAC terminal via ssh connection, receiving the below…

tractorparts@TRACTORPARTS:~$ bench setup scheduler
Usage: bench setup [OPTIONS] COMMAND [ARGS]…

Error: No such command “scheduler”.
tractorparts@TRACTORPARTS:~$ bench use site TRACTORPARTS
Usage: bench use [OPTIONS] SITE

Error: Got unexpected extra argument (TRACTORPARTS)
tractorparts@TRACTORPARTS:~$ bench enable scheduler
Usage: bench [OPTIONS] COMMAND [ARGS]…

Error: No such command “enable”.

@PaulTheTrouble sorry for the typos, please see below:

bench trigger-scheduler-event
bench use yoursitename
bench enable scheduler

ramiellan I get this error.

mtpi@server:~$ bench trigger-scheduler-event
Usage: bench trigger-scheduler-event [OPTIONS] EVENT

Error: Missing argument “event”.

have the same issue…

New install few days ago on Ubuntu server 14.04…in Virtualbox

what about the others?
did it pass through without errors?

The command “bench use site1.local” had no error
The command “bench enable scheduler” too gave the error

mtpi@server:~$ bench enable scheduler
Usage: bench [OPTIONS] COMMAND [ARGS]…

Error: No such command “enable”.

@Mohammad_Ahmad_Zulfi bench enable-scheduler

am sorry i dot have any servers to get info from thats why i have mistakes…

@ramielian Thanks man the commands “bench use site1.local” and “bench enable-scheduler” worked now but the problem is still there. The pages i mentioned before get freeze.

@Mohammad_Ahmad_Zulfi ok, can you please see what branch are you using ? master or develop?

@ramielian I use the following commands to install

sudo bash --setup-production

It installs with master branch. I don’t know how to find that out through the terminal

Hi @ramielian @vjFaLk ran the below commands also. Note (running on MAC Terminal on Microsoft Azure Ubuntu 14.04 VM)

I also still have the same problems… any ideas?

tractorparts@TRACTORPARTS:~$ bench trigger-scheduler-event
Usage: bench trigger-scheduler-event [OPTIONS] EVENT

Error: Missing argument “event”.
tractorparts@TRACTORPARTS:~$ bench use site1.local
tractorparts@TRACTORPARTS:~$ bench enable-scheduler
Enabled for site1.local

@PaulTheTrouble @Mohammad_Ahmad_Zulfi

Can you check your JS console (CTRL + SHIFT + I) and see what shows up?