Set Developer Mode

Hi Guys,

I want to commend you on the good work you are doing. Someone introduced me to Frappe Bench and i have been trying to see how best i can make use of it.

However, every time i try to create a DocType i get the error: Not in Developer Mode; set in site_config. Meanwhile, i have already added "developer_mode: 1 in site_config, but it still not working. I have also restarted frappe-web, frappe-worker and frappe-workerbeat all to no avail. Please help!

Please see this link:

Thank you for your reply.

I’m not sure you went through my post.

Please note that i have already added developer_mode: 1 in /frappe-bench/sites/library and it still won’t allow me to create DocTypes.

From what error you have reported, your developer_mode is not yet set.

Try doing

bench frappe --clear_cache and try again

Thank you rmehta for your help.

However, after bench frappe --clear_cache and bench frappe --flush_memcache i still can’t create DocTypes.

I get the error Not in Developer Mode! Set in site_config.json, but i have already added "developer_mode": 1 in my site’s site_config.json

Please is there anything else i need to do. I have been stuck on this for 2 days now.

Should work. There is nothing else I can think of. Maybe you are trying in the wrong site.

Sent from phone

Thank you once again rmehta.

Unfortunately, it turned out that i was adding it to the wrong site - like you have said. You guys need to update the document here: Enable Developer Mode, because it is very misleading. I just wasted 2days trying to implement what is described on the page.

A line there says To enable developer mode, update the site_config.json file of your site in the sites folder

Where as, one is supposed to update the site_config.json of the site1 in frappe-bench's sites folder and NOT your SITES site_config.json.

Anyways, thank you for your help. I really appreciate it.

I can now create DocTypes.


Hi @Abiodun_Ajibike,

I’m stuck too on this…can you share clear steps / command lists to enter development mode…

Thank you

Hi @rmehta the link that you provided is not found. Thanks!

Hi @Jonathan_Fanny_Lie,

To enter developer mode, you have to install frappe-bench from sratch; you cannot enter developer mode on a pre-configured frappe application.

To set developer mode for frappe on your development machine,

  1. Navigate to frappe-bench/sites/site1.local

  2. Open site_config.json and add "developer_mode": 1 to the dictionary in it. It is usually in this format:

    “db_name”: “sites1.local”,
    “db_password”: “xxxxxxxxxxxxx”
    “developer_mode”: 1

You may want to restart your development machine for this change to take effect.

Good luck


Hello, sorry to bring this up again but for accuracy I would like to correct a typo above, because it has been a problem for me a few times.

"db_name": "sites1.local",
"db_password": "xxxxxxxxxxxxx",
"host_name": "http://site1.local",
"developer_mode": 1

Make sure the fields are separated by commas.

I added host_name because it is used for emails from the system. This should be changed to the domain name you use to access ERPNext.


Thanks zeroxcorbin,
It helps me.

hi, the link is 404 page.


please check the following link


1 Like

dear all,

i need freelancer developer to make some changes in my erp next please any thing contact me in my account

Recuerda que el modo desarrollado solo funciona en la cuenta de administrador

1 Like