Translation export-Import issue

I have tried a couple of times with different approaches but is stonewalled.

I have made a rough translation through google translate but the import results in a terrible mess.


Ubuntu 14.04.2LTS - Ubuntu base-server with LXDE - clean install.
Locale da_DK-UTF-8 (corresponding keyboard).

Get frappe untranslated

bench frappe --get_untranslated da-dk ~/en-dk.txt

Update frappe translation

bench frappe --update_translations da-dk ~/en-dk.txt ~/da-dk.txt

The problem boils down to:

  • the exportfile has an empty line as the last line.
  • the google-translate-file has an empty line at the beginning and none at the end.

Adjusting the resulting translation to match to match the original as per lines makes no difference for the update_translations result.

The translated strings is thrown in something that looks like random, since the imported text is never the same.

Doing a rough side by side comparison in texteditor it shows the translated lines does match the corresponding untranslated as per linenumber.

I have not checked this in VBoxVM build but I have noticed that the locale used in the VM is en-IN.

Just a thought as writing this - could it a possible locale-configuration be the issue? I think not but nevertheless - the thought is passed on.

This is a huge bump - do you, by any chance, have a clue?

The translations is available per request.



You might want to check how your translations got built in the erpnext/translations/da-dk.csv


This is somewhat confusing.

As of yesterday:

  • I had to drop the primary setup process due to the update_translations had messed with the texts - I had no idea what I was doing.
  • I later logged in - just to confirm - the translations gave absolutely no sense.

Logging in now - AFAIS I am looking at the google-translated texts.

I am really having a hard time here - several other issues - not in the scope of this post.

Could be a bug / freak workflow / cache issue? Really hard to say without having a look at what you are doing? If you can send a Pull-Request, we can have a look.

@fhdk, did you solved it, I’m trying to export a custom translation, but with export-fixtures I’m not so sure if will work. Do you know if there’s another way to export a custom translantion. Thanks for Advance.