Updated DocType Def, Cleared cache, Bench Restart, Still Not refleceted

Hello Community,

I want to redefine School Defination as, Training. So, Changed “School” DocType Def to “Training”. & Similarly, “Course” to “Training Course”.

As Cleared Cache & followed below commands:

  1. bench setup redis
  2. bench clear-cache
  3. bench restart

Still, Not helped. Instead, renaming DocType, It’s invisible there from Modules Left Sidebar. Any help is appreciated.

Why don’t use custom translations?

@JoEz Thanks for reply. Looks great idea. I just though custom translation is only for localization.

Is this tip work here? If you had done this earlier, will you suggest me please, how I can achieve this without changing core. I think, if it just custom translation, would not interact to core.

Please brief me about this. This will help other community people as well. Thanks in advance.

You can do in Customize Form, choose the DocType …you can change name there …

1 Like

Hey @JoEz !! Thank you so much for reply.

Customize Form, will resolve sub-module renaming issues. But, I really want to change module name. As mentioned in question, DocType Def renames modules. But, next to rename, I lost it what exactly happening there. So, I created a video of my issue. Might able to understand, what I exactly wants.


I think you’re trying to do a weird thing …if you really want to change module name use custom translations instead …do not try to modify module definitions.

1 Like

@JoEz Can you please help me with this? Really, I tried & done research. Even though, I was there where you stands at my position.

Here you were: How to translate custom apps?

Query raised by you is unanswered. So, again lost in ocean.

In the search bar type Translation List, you could add translation there.


Finally, I got it. Thanks a lot @JoEz :grinning: