Why is a new user also a customer?

Newb question. I have noticed that the new users I have created appear in the Customer List. Why? Can a user be configured to not be a customer? It seems it might cause questions in a boardroom demo to see known non-customers listed in the Customer List. Am I missing something? Thanks.

Check if the Customer role is selected for the user.

1 Like

While creating new users you might’ve checked this field, hence it shows a user in the customer list. Uncheck this field to un-assign customer role to the user.

1 Like

@Dale_Scott Certain roles are checked by default while creating a new user, without your explicitly checking them.

1 Like

Thanks for your help. I am trying to create a “read-only” type of demo user, and did not notice there was a Customer role. Doh! However, it seems I cannot un-check Customer, after saving it is checked again.

Here is the user config. Could it be that the Customer role is required for some reason?

What version are you on? I tried this and just after creating the user all roles were checked. I cleared all roles and saved the user it worked.

Did you assign any additional permissions to the user?

1 Like

Hi @kennethsequeira. I’m using the vm image, it was downloaded ~6 weeks ago, and I ran “bench update” once ~4 weeks ago. How does one report what version is running? Is that the last repo commit locally? .

frappe@erpnext:~/frappe-bench/apps/erpnext$ cd ~/frappe-bench/apps/erpnext
frappe@erpnext:~/frappe-bench/apps/erpnext$ git log | head
commit 94704beba378804b4acffb57133e943dff818195
Merge: 3f83afe 429e5d5
Author: Nabin Hait <nabinhait@gmail.com>
Date:   Wed Nov 15 14:08:17 2017 +0530

    Merge branch 'hotfix'

commit 429e5d57d56a361b144e84ee72bfca8ad277958a
Author: Nabin Hait <nabinhait@gmail.com>
Date:   Wed Nov 15 14:38:17 2017 +0600

I created the user using menu Setup > User > New, and did not intentionally assign any additional permissions. I merely un-selected all the roles that seemed likely to allow data entering/editing.

Fwiw, just now I selected “Clear all roles” and still Customer came back checked after saving. It’s very late here (03:30), maybe this will make more sense in the morning…

You can check the versions by doing a ‘bench version’

It is best to stay updated. ERPNext is coming out with version 10 this week.

1 Like

Thanks @kennethsequeira and @pratu16x7 for your input. I have since reverted my system (for other reasons) to before I had created the “read-only” user, and re-creating the user again now all roles are de-selected in the new user profile - as expected. I was able to assign user-type roles without Customer getting selected. Call it finger trouble I guess…

I also am experiencing this. I don’t quite understand it. If I create a new-user right now, I can check/uncheck the CUSTOMER role, and it works just fine. However, on a user which I created previously, (maybe there are multiple ways to enter the “create user” screen?) I cannot get the role to remain UNchecked.

I just downloaded the virtual-appliance a couple days ago. According to bench --version I am at 4.1.0.

I also noticed that with every other role, I can click on the role and it pops up a description of the permissions that role gives. However, if I click on CUSTOMER, nothing happens. The ajax call goes out, but it is returning an empty JSON dataset…



Not sure what I did to end up with a user setup this way, but here is what the issue was…

I went to delete the user, and it said it could not delete, due to the user being linked with a contact. I was able to click on the contact-name in the message, and it brought me to a contact-record, where there was a reference table, with a row which said CUSTOMER under the Link DocRef column. I deleted this row, saved the contact, then went back to the user-record, and now I am able to remove the CUSTOMER role.

Just posting this in case someone else runs across this issue.

Welcome to ERPNext and thanks for documenting your learning tip David.

Just fyi, the bench is the utility used to access and run erpnext that is built on top of frappe, where the three exist as distinct code bases.

So in your case you may want to refer to this version info too:

frappe@ubuntu:~/frappe-bench$ bench version
erpnext 10.1.20
frappe 10.1.21

cheers and thanks

Gotcha! I just assumed I needed to use “bench --version” when I ran “bench version” outside the /frappe-bench folder and got “Error: No such command ‘version’”

Thanks for clearing that up,