Contribute Chart of Accounts for your country

Dear everyone,

We are very happy to launch our second contribution portal. Contribute a default chart of accounts for your country!

See how it works:


Hi there Team,

I registered and I would like to contribute with the Spanish Chart of Accounts, but I don’t understand the process to download and install / apply the chart of accounts from

Could you help me with a small guide / process of implementing a new Chart of Accounts from the new portal?

I have already clones the git GitHub - frappe/chart_of_accounts_builder in my frappe-bench directory /also tested in apps) and after that executed the command

bench --site nameofmysite execute chart_of_accounts_builder.utils.setup_charts

OSError: [Errno 2] No such file or directory: ‘./sites’

So, I’m missing sth on the process of downloading the git application and using it… Or the general process of using the new portal.

Kind Regards

@rtimagine the portal is where you contribute and it will be included in future versions of the product. Just sign-up for the portal, fork a chart or start a new chart and modify it and submit it.

See this page on how to contribute:


This is cool and really needed. How can I import relevant chart of accounts into my existing cloud erpnext AC?
E.g .Singapore

@rmehta hi there, any chance to import a chart (in charts.expnext) using an import tool? instead of writing manually 1500 rows?

Thanks in advance


Tried to customize the es-NI CoA, every time I try to translate and
set the correct Root It says “Root Type is mandatory” after clicking on
submit, where all Roots account’s name are set.

Another issue is that, when trying to write something since there are
some words in english, I cannot type anything, I have to copy and
delete the string by using the browser altern menu.


@nabinhait @Pawan can you help?

@axatech01, below are the steps that generally help me make changes to CoA’s,hope you find these helpful to resolve some of the issues you are facing:

  1. If the CoA already exists, fork the CoA and then make changes.
  2. Once you click on submit, it would give you a message with the Node name for which root type is not set.Using this node name you can search the tree and set the root type appropriately.
  3. Use google translate for any help needed for translation, you would need chrome browser for this and select the ‘always translate’ option.
  4. Sometimes root of the tree(topmost node) root type is not set. This also would give you a message saying “Root type is mandatory”, you can set it appropriately and move ahead.

The typing while using edit/rename functionality is not working currently and we are working to resolve that.



The issue with edit/rename and not being able to type into the field is also resolved now.

Thanks @Pawan. Now It Worked as stated.

Hi, I have the same question that @wdg , and I did not find response throughout the forum.


Hi @Pawan, any idea for de wdg question?

This is cool and really needed. How can I import relevant chart of accounts into my existing cloud erpnext AC?
E.g .Singapore



  • You can go to

  • Fork your country COA and submit it.

  • Once it is reviewed it can be merged into ERPNext.

Currently Singapore COA is already submitted, you can review it from and see if it meets your requirements.

Thanks Pawan, but I need the chart of accounts that is there (example Argentina).

When I choose the country in the initial setup takes the chart of accounts showing in Because I compare them and are not equal.

I appreciate an answer, sorry if I’m not understanding something that looks basic.


  • Currently it would take default CoA and not the one in

  • is a way you can contribute your own Country’s CoA to ERPNext

  • There is a plan is to merge few submitted CoA’s from into ERPNext, you would then see them in ERPNext based on your country selected.

Hope this clarifies some of your queries.


1 Like

Thanks @Pawan !!!

Hi @Pawan,
i was create new chart last night for my country but i was not able to add root account. Button is grey?

Thanks for reporting, fixed it.

Thank you for fix this @nabinhait

Hi @nabinhait. I just start to create first root accounr. I enter name, select root type and when i wan’t to save nothing happens. Form is not moving. Can you fix this please?