When I create a new workspace I cant add it to a custom module

When I create a new workspace the field for adding it to a module is missing.

First, create a workspace and then go to the workspace doctype and add the module.

1 Like

The module field is missing when I follow these steps.

You developer mode is disabled so that is the problem.

You have to enable the developer mode, after then module is appers.

Please apply the command to enabled the developer mode.

bench set-config developer_mode 1

// OR

bench --site [your_sitename] set-config developer_mode 1

Great thank you, does having the system in developer mode affect a production environment? After making changes should the developer mode be put back to 0.

Short Answer Yes!

Long Answer

  1. Create Custom App
  2. Export changes to it
  3. push to github
  4. Deploy to production

i.e keeping dev and prod seprate