No Journal Entry for Payroll Process


I processed payroll successfully and submitted payslips but there is no journal entry for the payroll components. I’ve checked every component to be sure appropriate journal accounts were selected but still the payroll transactions are not reflecting. Is this a bug issue? I’ve searched and found similar posts but there seem to be no answer to the issue. I would appreciate if someone can tell me what i could be doing wrong.

Hi @flexy2ky

I have checked on local account and it’s working properly

  • I have set the default account against the company

  • Also set the default payroll account in the company.

  • Created and submitted salary slip from process payroll and system has created journal entry of expense booking.

  • Then selected Payment Account on process payroll and clicked on Make Bank Entry button.

As payroll has accrual accounting, you need to set default account on each component.

@rohit_w Thanks a bunch!!! I realized i did not select the default payroll payable account against the company. That’s where the error was coming from. The payroll process hits the accounts automatically now.

But i encountered another problem relating to payroll processing. The payslip process times out while trying to submit. The error relates to wkhtmltopdf:

File “/home/frappe/frappe-bench/env/src/pdfkit/pdfkit/”, line 140, in to_pdf
raise IOError(‘wkhtmltopdf reported an error:\n’ + stderr.decode(‘utf-8’))
IOError: wkhtmltopdf reported an error:
Exit with code 1 due to network error: HostNotFoundError

I have searched through several posts on this issue and the suggestion is to add “host_name”: “localhost:8000” to the site_config.json file. But once i do that erpnext crashes and so i have to reverse the edit. My instance is currently hosted on amazon web services. Is it possible to educate me on what to do so i can solve this once and for all?


Hi @flexy2ky

This is for local machine not for the cloud server. You need to set your domain name(application URL) to host name in the site_config.json file

@rohit_w pardon my persistence but i’m a noob so i cannot figure out the application url for aws or how to find it. I tried using the DNS name but this threw my erpnext instance offline, giving me an internal server error.

Please also confirm if this is the right config file i am supposed to modify:

“db_name”: “xxxxxxxxxxxx”,
“db_password”: “xxxxxxxxxxxxxxxxxxxx”,
“encryption_key”: “xxxxxxxxxxxxxxxxxxxx”,
“limits”: {
“space_usage”: {
“backup_size”: 4.0,
“database_size”: 16.24,
“files_size”: 2.0,
“total”: 22.24

it is located in ~/sites/site1.local/site_config.json

i could really use your advise to get this working.



Try in Website settings

Hope this helps.

How do you open the application in the browser? Can you share the URL?

This is the URL: i did enter this in site_config.json then the site gives an error requiring administrator attention.

@krnkris unfortunately no it doesn’t help. Like i mentioned in my earlier post, i’m a noob and a i really can’t do much with the post on the other thread attached.

You have to purchase new domain name(same as site name), map it to the above ip address, and set same to the host_name in the site config file.
For more details check below post

@rohit_w i don’t know what just happened but i have just lost access to my instance. i am now getting internal server error after giving out my ip address. I have tried to restore by database to the last backup but i am getting this error:

Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/”, line 72, in _run_code
exec code in run_globals
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 94, in
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 18, in main
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 24, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 110, in restore
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 57, in _new_site
installing = touch_file(get_site_path(‘locks’, ‘installing.lock’))
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 332, in touch_file
with open(path, ‘a’):
IOError: [Errno 13] Permission denied: u’./site1.local/locks/installing.lock’

my running instance has now stopped and i did not do anything. I was hoping to use the instruction on your last post but now i don’t know what to do.

Seems you have run the wrong command, what command did you run?

Remove the lock file installing.lock from the locks folder and check again

@rohit_w this is the command i tried to use to restore the backup:

ubuntu@ip-xxx.xx.xx.xx:/home/frappe/frappe-bench$ sudo bench --site site1.local --force restore /tmp/20170831_000240_861e98dc_database.sql

i have created another bench site now using a domain name. i already have " which is also set to redirect to my ip address on port 80. but the new site created redirects to port 8001.

why are you using sudo? Try without sudo

without sudo it gives me this error:

Database not installed, this can due to lack of permission, or that the database name exists.
Check your mysql root password, or use --force to reinstall

i am running the command from this directory:


Seems database is not exist, kindly check first database of your site is exist, you can check the database name from the site config file

@rohit_w this is the content of my site config file:

“db_name”: “1bd3e0294da19198”,
“db_password”: “blahblahblah”,
“encryption_key”: “blahblahblah”,
“limits”: {
“space_usage”: {
“backup_size”: 3.0,
“database_size”: 16.26,
“files_size”: 2.0,
“total”: 21.26
“site_config.json” [noeol] 13L, 273C 1,1 All

Hi @flexy2ky

Are you using frappe user?

@rohit_w no i am using ubuntu user. That’s the default user that was installed with the instance